ACCESS - istituto san giuseppe del caburlotto

annuncio pubblicitario
MODULO 5 – DATABASE
Sezione
Tema
Rif.
5.1
5.1.1
5.1.1.1
Usare
Concetti
l’applicazio fondamentali 5.1.1.2
ne
(ACCESS) [Il programma qui utilizzato è Microsoft Access 2002]
Argomento
Sapere cosa è un E' una raccolta di informazioni opportunamente organizzate, in
database. [1]
forma digitale.
Sapere come è
organizzato un
database in
termini di
tabelle, record,
campi, e di tipi
di dati, proprietà
per i campi.
I dati nei database sono sempre organizzati in tabelle. All'interno
della tabella le righe sono chiamate RECORD (contengono tutte
le informazioni relative ad un elemento del nostro database; ad
esempio un cliente); i record sono formati da CAMPI (in ogni
campo, cioè in ogni cella delle riga, è contenuta una
informazione; ad esempio l'indirizzo, la data di nascita,...). Ad
ogni campo deve essere dato un nome (es. "Indirizzo") e deve
essere specificato il tipo di dato che contiene, scelto fra quelli
proposti, (ad es. testo, data/ora, ...).
Al campo inoltre devono essere attribuite delle proprietà (ad es.:
la dimensione massima del testo da inserire, il formato del
carattere per migliorarne la leggibilità, ...) Queste scelte potranno
essere effettuate costruendo la tabella in modalità
"STRUTTURA"
5.1.1.3
Sapere cosa è
una chiave
primaria.
5.1.1.4
Sapere cosa è un E' una proprietà del campo (quindi può essere scelta nella scheda
indice.
proprietà, dopo aver visualizzato la tabella in modalità
"struttura") che permette di trovare e ordinare i record più
rapidamente.
5.1.1.5
Sapere quali
sono le
motivazioni per
creare relazioni
tra tabelle di un
database.
Creare relazioni tra tabelle consente di evitare di ripetere gli stessi
dati in più tabelle (ad es.:memorizzando il dato in un solo campo
e mettendo in relazione tabelle diverse con quel campo, in quella
tabella), ma serve anche a migliorare la ricerca e l'analisi dei dati.
5.1.1.6
Sapere qual è
l’importanza di
impostare delle
regole per
assicurare che le
relazioni definite
tra tabelle siano
valide.
E' importante impostare la cosiddetta INTEGRITA'
REFERENZIALE (cioè l'insieme di regole per assicurare che le
relazioni definite tra tabelle siano valide) per impedire che
vengano eliminati o modificati per errore i dati correlati, o che
vengano correlati dati con campi vuoti.
5.1.2 Primi 5.1.2.1
passi con un
database
5.1.2.2
E' un campo (che quindi contiene al suo interno un dato) che
permette di identificare uno e un solo record all'interno di una
tabella (ad es. il codice numerico di un cliente). Una chiave
primaria permette di mettere in relazione più tabelle fra loro (per
ogni tabella è quindi consigliabile impostare sempre una chiave
primaria) ed evita l'inconveniente di avere a che fare con tabelle
enormi e con dati duplicati. Ci sono tre tipi di chiavi primarie:
contatore (creata automaticamente, assegna un numero
sequenziale ad ogni record) Campo singolo (assegnate a campi
che contengono valori univoci come il codice fiscale o la targa
auto) Multicampo (unisce più di un campo per creare una chiave
primaria)
Aprire (e
(per aprire) dalla barra delle applicazioni:
chiudere)
start/programmi/microsoft office/microsoft Access opp. Icona
un’applicazione sul desktop
di database.
(per chiudere) dalla barra dei menu: file/esci oppure dalla barra
del titolo: cliccare sulla croce
Aprire,
Apri file esistente/seleziona il database richiesto (opp.
collegarsi ad un selezionare Altri file) e premi OK (opp. continua la ricerca)
database
esistente.
5.1.2.3
Creare un nuovo Crea nuovo database/seleziona database di Access vuoto
database.
opp. File/Nuovo/Database/OK
5.1.2.4
Salvare un
database
all’interno di
un’unità disco.
Quando si crea un nuovo database viene chiesto immediatamente
il nome che si vuole assegnare al file e su quale unità lo si vuole
salvare. I comandi File/Salva o Salva con nome permettono di
salvare solo i singoli oggetti del database o di cambiare loro il
nome.
5.1.2.5
Usare la
funzione di
guida in linea
(help) del
programma.
Cliccare sul ? nella barra dei menu/Guida in linea/scegliere fra:
sommario - ricerca libera - indice (digitare la domanda o la parola
cercata) cliccare su cerca
5.1.2.6
Chiudere un
database.
dalla barra del titolo del database: cliccare sulla croce
Cambiare le
modalità di
visualizzazione
di una tabella,
maschera, report.
Selezionare l'oggetto (tabella, maschera, report)
Mostrare,
nascondere le
barre degli
strumenti.
Menu Visualizza/barre degli strumenti (selezionare o
deselezionare)
5.1.3
5.1.3.1
Modificare
le
impostazioni
5.1.3.2
5.2 Tabelle 5.2.1
5.2.1.1
Operazioni
fondamentali
Per passare dalla modalità visualizzazione struttura (che
permette di modificare le impostazioni, di visualizzare i tipi di
dati e le relative proprietà) alla modalità visualizzazione foglio
dati (che permette di visualizzare il contenuto di ciascun campo e
di modificare i dati in ciascun record) si clicca sul pulsante
Struttura della barra degli strumenti o sul pulsante Foglio dati
che si alternano come primo pulsante a sinistra della barra degli
strumenti del database (per il report, il pulsante si chiama
visualizza struttura, anteprima di stampa o layout ed è sempre
il primo pulsante a sinistra della barra degli strumenti).
Creare e salvare Una tabella può essere creata in tre modi diversi: nella finestra di
una tabella,
sinistra del database selezionare l'oggetto: Tabella; cliccare su
specificare i
una delle tre icone:
campi con i
relativi tipi di
a. Crea una tabella mediante l'immissione di dati
dati.
b. Crea una tabella in visualizzazione Struttura
c. Crea una tabella mediante una creazione guidata
fare doppio clic sulla voce d'interesse (opp.premere sul pulsante
Nuovo della barra degli strumenti). Analizziamo i tre casi:
1. Crea una tabella mediante l'immissione di dati. viene
visualizzata una tabella vuota che possiamo modificare
facendo doppio clic sulle voci Campo1, Campo2,... e
inserendo i nomi dei campi (es.: Cognome; Nome; Data di
nascita; Codice cliente; ...) Dopo aver completato
l'inserimento del nome dei campi, si possono inserire per ogni
riga sottostante i dati dei nostri clienti. Con questa modalità
però non è possibile scegliere il tipo di dato da inserire nel
campo, esso viene impostato come "solo testo"
2. Crea una tabella in visualizzazione Struttura: si apre la
finestra che mostra la "struttura" della nostra tabella, in cui
vanno digitati i nomi di tutti i campi, nella colonna Nome
campo (es.: Cognome; Nome; Data di nascita; Codice
cliente; ...). Per ogni campo, nella colonna Tipo dati, deve
essere selezionato il tipo più appropriato scegliendo fra quelli
della lista che compare nel menu a tendina (es.: per i campi
Nome e Cognome si dovrà selezionare il tipo Testo; per il
campo Data di nascita si dovrà selezionare il tipo Data/Ora;
per il campo Codice cliente si dovrà selezionare il tipo
Numerico; ...) Per i Tipi di dati si veda la Tabella1 allegata.
Per ogni campo, nella colonna Descrizione è facoltativo
inserire informazioni utili. Per ogni campo, nella parte
inferiore della finestra, si possono impostare anche delle
Proprietà campo compilando la scheda Generale (es.:
Dimensione, Valore predefinito,...). Per la descrizione delle
Proprietà campo da inserire nella scheda Generale si veda la
Tabella2 allegata
3. Crea una tabella mediante una creazione guidata: viene
visualizzata la procedura guidata per la compilazione della
tabella.
Per salvare la tabella, dalla barra dei menu file/salva opp. salva
con nome oppure al momento in cui viene chiusa compare
automaticamente il messaggio di richiesta del salvataggio in cui
immettere il nome della tabella.
5.2.1.2
Inserire,
Fare doppio clic sulla tabella, o aprirla in modalità visualizza
eliminare record foglio dati (pulsante Apri dalla barra degli strumenti). Dalla barra
in una tabella.
dei menu: Inserisci/Nuovo record opp. cliccare sul pulsante
Nuovo record sulla barra di stato (nella parte inferiore della
finestra Tabella contrassegnato da >*), oppure posizionarsi
sull'ultima riga della tabella, sempre vuota e contrassegnata da *,
pronta ad accogliere dati. Il nuovo record viene sempre
posizionato in fondo alla tabella.
Per eliminare un record posizionarsi con il mouse a sinistra del
record e cliccare ( viene selezionata l'intera riga).
Cliccare quindi sul pulsante Elimina Record dalla barra degli
strumenti e confermare la scelta nella successiva finestra di
dialogo. (Attenzione: a questo punto i dati di quel record non
possono essere più recuperati!).
La stessa operazione si può fare dalla barra dei menu:
Modifica/Elimina record oppure col tasto destro del mouse
scegliendo Elimina Record, oppure con il tasto CANC della
tastiera.
5.2.1.3
Inserire un
Cliccare sul pulsante visualizza Struttura della barra degli
campo in una
strumenti, posizionarsi con il puntatore nella colonna Nome
tabella esistente. campo in una riga vuota digitare il nome del campo.
Se si desidera inserire un campo fra quelli esistenti: posizionarsi
nel punto in cui si vuole inserire il campo scegliere dalla barra dei
menu Inserisci/Righe, la stessa operazione si può fare
utilizzando il tasto destro del mouse e il menu contestuale
Inserisci righe.
5.2.2
Definire le
chiavi
5.2.3
Definire/
impostare
una tabella
5.2.1.4
Inserire,
modificare dati
in un record.
Fare doppio clic sulla tabella, o aprirla in modalità visualizza
foglio dati (pulsante Apri dalla barra degli strumenti).
Posizionare il mouse nella cella del record da modificare. Inserire
i dati nel record (cioè nella riga) o modificarli digitandoli
direttamente I dati immessi vengono automaticamente salvati
quando ci si sposta su un altro record.
Per passare al record (riga) successivo, utilizzare il puntatore del
mouse o i tasti freccia dalla tastiera, oppure i pulsanti Record
sulla barra di stato (nella parte inferiore della finestra Tabella)
5.2.1.5
Eliminare dati da Posizionarsi nella cella che contiene i dati da eliminare,
un record.
selezionarla e premere il tasto CANC opp. dal menu
modifica/Elimina. In alternativa si può utilizzare il tasto
BACKSPACE.
5.2.1.6
Usare il
comando
“Annulla”.
Ogni modifica fatta nel record può essere annullata
immediatamente con il pulsante Annulla della barra degli
strumenti, o dalla barra dei menu Modifica/Annulla digitazione
(attenzione il pulsante annulla permette di annullare solo le
modifiche fatte al record che si sta modificando o che si ha
appena finito di modificare)
5.2.1.7
Navigare in una
tabella al record
successivo,
precedente,
primo, ultimo, e
su un record
specifico.
Per passare al record (riga) successivo, precedente, primo, ultimo,
utilizzare i pulsanti Record sulla barra di stato (nella parte
inferiore della finestra Tabella), per posizionarsi su un record
specifico digitare direttamente il numero della riga nella Casella
del Record (quella al centro dei pulsanti Record sulla barra di
stato) e premere invio.
5.2.1.8
Cancellare una
tabella.
Selezionare la tabella dalla finestra Database; dalla barra dei
menu: Modifica/Elimina (oppure pulsante X (Elimina) dalla
barra degli strumenti oppure tasto destro del mouse/Elimina
oppure tasto CANC da tastiera)
5.2.1.9
Salvare e
chiudere una
tabella.
File/salva (se si vuole mantenere lo stesso nome alla tabella)
File/Salva con nome (se si vuole cambiare nome alla tabella,
creandone una copia) Per chiudere la tabella cliccare sul pulsante
a croce nella barra del titolo della tabella o File/Chiudi dalla
barra dei menu di Access
5.2.2.1
Definire una
Aprire la tabella in Visualizzazione struttura, selezionare il
chiave primaria. campo e cliccare sul pulsante Chiave primaria sulla barra degli
strumenti di Access
5.2.2.2
Indicizzare un
campo con,
senza duplicati.
Aprire la tabella in Visualizzazione struttura, selezionare il
campo e nella parte inferiore della finestra, nelle Proprietà
campo all'interno della scheda Generale cliccare sulla casella
Indicizzato, quindi cliccare su Sì (Duplicati possibili) oppure su
Sì (Duplicati impossibili)
5.2.3.1
Modificare gli
attributi di
formato di un
campo, quali:
dimensioni,
formato
numerico,
formato data.
Aprire la tabella in Visualizzazione struttura, selezionare il
nome di un campo; si possono modificare dimensioni, formato
numerico, formato data nella scheda Generale delle Proprietà
campo:
se il tipo di dati è Testo nella casella Dimensioni si può inserire
una dimensione diversa digitando il numero di caratteri richiesti
(es. 55, ...);
se il tipo di dati è Numerico nella casella Dimensioni si può
scegliere una dimensione diversa fra quelle del menu a tendina;
nella casella Formato se ne può scegliere uno diverso allo stesso
modo (es. formato Valuta, opp Percentuale,..);
se il tipo di dati è Data/Ora nella casella Formato se ne può
scegliere uno diverso sempre fra quelli del menu a tendina (es.
formato Data estesa, opp Data breve,..)
5.2.3.2
Sapere quali
conseguenze si
ottengono
modificando gli
attributi di
dimensione dei
campi di una
tabella.
Modificando gli attributi di dimensione dei campi si definisce la
lunghezza massima dei dati inseribili nel campo (ad es. si
impediscono alcuni errori )
Se il campo contiene dati di tipo Testo: dimensioni di dati più
ridotte possono inoltre essere elaborate con più velocità e
richiedono minore quantità di memoria; se il campo contiene dati
di tipo Numerico occorre ricordare che i diversi formati
permettono di memorizzare diversi tipi di numeri (interi o
decimali o frazioni)
5.2.3.3
Creare una
semplice regola
di validazione
per numeri,
testo, data/ora,
valuta.
Aprire la tabella in Visualizzazione struttura, selezionare il
nome di un campo; nella scheda Generale: alla voce :Valido se,
inserire le regole di validazione (es:
per numeri: >=0; Between 0 And 1;
per testo: Like "A????" cioè il valore immesso deve essere di
cinque caratteri e cominciare con la lettera A;
per data/ora: <#1/1/96# cioè immettere una data anteriore al
1996;
per valuta: <>0 cioè diverso da zero; 0 Or >1000 cioè il valore
immesso deve essere 0 o maggiore di 1000.
5.2.3.4
Cambiare
l’ampiezza delle
colonne di una
tabella.
Aprire la tabella in modalità visualizza foglio dati, portare il
puntatore del mouse sul bordo destro della casella contenente il
nome della colonna, trascinare il puntatore tenendo premuto il
tasto sinistro del mouse; se si selezionano più colonne
consecutive questa procedura permette di ridimensionarle tutte
contemporaneamente. La stessa operazione può essere fatta in
altri due modi: selezionare le colonne;


scegliere dalla barra dei menu Formato/Larghezza
colonne
con il tasto destro del mouse e scegliendo Larghezza
colonne dal menu contestuale
5.2.3.5
Spostare una
colonna
all’interno di una
tabella.
Aprire la tabella in modalità visualizza foglio dati, portare il
puntatore del mouse all'interno della casella contenente il nome
della colonna, trascinare la colonna nel punto desiderato tenendo
premuto il tasto sinistro del mouse
5.2.4
5.2.4.1
Relazioni tra
tabelle
Creare una
relazione uno-auno, uno-a-molti
tra tabelle.
Strumenti/Relazioni si apre una finestra vuota se non ci sono
relazioni già definite; dalla barra dei menu cliccare su
Relazioni/Mostra tabella; selezionare la tabella da mettere in
relazione e cliccare su Aggiungi, ripetere l'operazione per tutte le
tabelle coinvolte nella relazione; infine cliccare su Chiudi.

Relazione uno-a-uno: (Ad es.nel modo appena descritto si può
creare una relazione fra la tabella "Clienti" che contiene i
seguenti campi: CodiceCliente; Nome; Cognome; Scadenza
Abbonamento e la tabella "ArchivioFilm" che contiene:
CodiceFilm; Titolo; Regista; Durata; CodiceCliente) Nella
finestra appaiono le tabelle con la loro struttura; trascinare il
campo "CodiceCliente"-chiave primaria- della tabella
"Clienti" in quello "CodiceCliente" della tabella
"ArchivioFilm". Nella finestra Modifica relazioni fare clic
sul bottone Crea.

Relazione uno-a-molti: (Ad es.si può creare una relazione fra
la tabella "Registi" che contiene i seguenti campi:
NomeRegista; Anno di nascita; Titolo film; e la tabella
"ArchivioFilm" che contiene: CodiceFilm; Titolo; Regista;
Durata; CodiceCliente) Nella finestra appaiono le tabelle con
la loro struttura; trascinare il campo "NomeRegista"-chiave
primaria- della tabella "Resgisti" in quello "Regista"della
tabella "ArchivioFilm".
Attenzione: in una relazione uno-a-uno ogni record della tabella
A può avere solo un record corrispondente nella tabella B e
viceversa. Una relazione uno-a-uno viene creata se entrambi i
campi correlati rappresentano chiavi primarie o hanno indici
univoci.
In una relazione uno-a-molti un record della tabella A può avere
molti record corrispondenti nella tabella B, ma un record della
tabella B non ha più di un record corrispondente nella tabella A
Una relazione uno-a-molti viene creata se solo uno dei campi
correlati rappresenta una chiave primaria o ha un indice univoco.
5.3
Maschere
5.2.4.2
Cancellare
relazioni tra
tabelle.
Strumenti/Relazioni si apre una finestra contenete le relazioni
già definite, fare clic sulla linea che visualizza la relazione,
premere il tasto CANC dalla tastiera e confermare la scelta nella
finestra di dialogo (oppure fare clic sulla linea che visualizza la
relazione e cliccare sul pulsante X (Elimina) della barra degli
strumenti)
5.2.4.3
Applicare una o
più regole ad una
relazione tali che
i campi coinvolti
nella relazione
non possano
essere cancellati
finché esistono
dati che
collegano le
tabelle.
Strumenti/Relazioni si apre una finestra contenete le relazioni
già definite, fare clic sulla linea che visualizza la relazione, nella
finestra Modifica relazioni spuntare la voce "Applica integrità
referenziale" disattivare "Elimina record correlati a catena"
Aprire una
maschera.
Nella finestra di sinistra del database selezionare l'oggetto:
Maschera; selezionare la maschera che si desidera aprire e
cliccare sul pulsante Apri della barra degli strumenti (oppure fare
doppio clic su di essa)
5.3.1
5.3.1.1
Operare con
le maschere
5.3.1.2
Creare e salvare Nella finestra di sinistra del database selezionare l'oggetto:
una maschera.
Maschera; premere Nuovo, cliccare su Creazione guidata
maschera (questa è la modalità richiesta dall'ECDL, mentre più
in generale si potrebbe aprire Crea una maschera in
visualizzazione struttura). Scegliere la tabella (o le tabelle) da
cui prelevare i dati che verranno visualizzati mediante la
maschera, quindi scegliere il campo e cliccare su > per inviarlo
nel riquadro campi selezionati (oppure >> per inviarli tutti
contemporaneamente); cliccare su Avanti; scegliere il Layout
(cioè la disposizione) dei campi sulla maschera; cliccare su
Avanti; scegliere lo stile da utilizzare; cliccare su Avanti;
impostare un titolo per la maschera; scegliere se terminare
visualizzando la modalità Struttura (quella in cui si può
modificare il layout) oppure la modalità in cui è possibile
introdurre o visualizzare dati; cliccare su Fine.
Per salvare l'oggetto maschera all'interno del database, utilizzare i
comandi File/Salva o File/Salva con nome che permettono di
salvare i singoli oggetti del database o di cambiare loro il nome.
5.3.1.3
Utilizzare una
Aprire il database; aprire l'oggetto Maschere selezionare la
maschera per
inserire,
modificare,
cancellare
record.
maschera; premere il pulsante Apri (o cliccare due volte)
utilizzare i pulsanti Record per spostarsi al punto desiderato e
modificare un record, oppure inserire un nuovo record (>*); per
spostarsi all'interno di una maschera utilizzare il tasto TAB; per
cancellare dati utilizzate il tasto BACKSPACE. Per cancellare
un record, posizionarsi a sinistra del record (dove compare la
freccia nera) cliccare selezionando tutto il record e cliccare sul
pulsante X (Elimina) record dalla barra degli strumenti.
5.3.1.4
Spostarsi sul
record
successivo,
precedente,
primo, ultimo, e
su un record
specifico
attraverso la
visualizzazione
maschere.
Per passare al record successivo, precedente, primo, ultimo,
utilizzare i pulsanti Record sulla barra di stato (nella parte
inferiore della finestra Maschera), per posizionarsi su un record
specifico digitare direttamente il numero della riga nella Casella
del Record (quella al centro dei pulsanti Record sulla barra di
stato) e premere invio.
5.3.1.5
Inserire,
modificare testo
nell’intestazione,
piè di pagina di
una maschera.
Aprire il database; aprire l'oggetto Maschere selezionare la
maschera e cliccare su Struttura;
5.3.1.6
Cancellare una
maschera.
Nella finestra del DataBase, selezionare la maschera e premere
CANC da tastiera oppure cliccare sul pulsante X (Elimina) della
barra degli strumenti.
5.3.1.7
Salvare e
chiudere una
maschera.
Per salvare File/Salva. Per chiudere : pulsante di chiusura nella
barra del titolo della maschera opp. File/Chiudi
Usare il
comando di
ricerca per
trovare una
parola, numero,
data specificati
in un campo.
Fare doppio clic sulla tabella, o aprirla in modalità visualizza
foglio dati (pulsante Apri dalla barra degli strumenti). Sulla barra
dei menu Modifica/Trova, si apre una finestra di dialogo digitare
una parola, numero, data,...; controllare che nella casella "Cerca
in" sia selezionata la tabella, poi cliccare su "Trova successivo".
5.4 Cercare 5.4.1
5.4 1.1
informazion Operazioni
i
fondamentali
Attenzione:la finestra che appare è suddivisa in tre aree:
“intestazione maschera”; "corpo"; “Piè di pagina maschera”
(se così non fosse Visualizza/Intestazione e piè di pagina di
una maschera). Il corpo contiene i controlli (o oggetti) che
sono di due tipi: etichette (titolo o nome dei campi) caselle di
testo (quelle bianche con i dati). Nell’area “intestazione
maschera” e “Piè di pagina maschera” è possibile inserire testo:
cliccare sul pulsante Aa (Etichetta) della Casella degli
strumenti: e aprire un rettangolo, quindi digitare il testo e
premere INVIO. (attenzione per formattare il testo si deve
formattare tutta l'etichetta, cioè uscire dall'etichetta, poi
selezionarla e modificarne il formato).
Per modificare testo: cliccare due volte all'interno dell'etichetta e
fare le modifiche.
5.4.1.2
5.4.1.3
5.4.2 Query 5.4.2.1
5.4.2.2
Applicare un
filtro ad una
tabella,
maschera.
Fare doppio clic sulla tabella o sulla maschera, o aprirla in
modalità visualizza foglio dati; selezionare il dato da filtrare:
Eliminare un
filtro da una
tabella,
maschera.
menu Record/Rimuovi filtro e oppure pulsante ad imbuto
(Applica filtro/Rimuovi filtro)
Creare e salvare
una query su una
sola tabella, su
due tabelle
usando dei
criteri di ricerca
assegnati.
La Query è uno strumento che consente di formulare specifiche
domande al DB in modo da poter estrarre e visualizzare ( da una
o più tabelle) solo i record che soddisfano determinati criteri.
Aggiungere
criteri ad una
query
Visualizzare la query in modalità Struttura e alla voce "criteri"
nella parte inferiore della finestra, digitare la formula che
interessa.
a. FILTRO in base a selezione: (es. per la ricerca dei clienti che
risiedono a Borgosesia) selezionare il dato Borgosesia
all'interno di una cella, menu Record/Filtro/Filtro in base a
selezione (o pulsante sulla barra degli strumenti a forma di
imbuto con evidenziatore);
b. FILTRO ad esclusione di selezione: (es. per la ricerca dei
clienti che non risiedono a Borgosesia) selezionare il dato
Borgosesia, menu Record/Filtro/Filtro ad esclusione
selezione.
c. FILTRO in base a maschera: menu Record/Filtro/Filtro in
base a maschera (oppure pulsante imbuto con maschera),
quindi usando il menu a scorrimento, selezionare nei vari
campi la parola o le parole in base alle quali filtrare, quindi
cliccare su Filtro/ApplicaFiltro o pulsante Applica filtro
(imbuto).
Per creare una query selezionare l'oggetto "Query" nella finestra
di sinistra del DB, quindi dalla barra degli strumenti scegliere
Nuovo, selezionare Creazione guidata Query Semplice poi
OK.
Per creare una query su una sola tabella selezionare la tabella su
cui effettuare la query (ad es. tabella "Clienti"); selezionare il
campo della tabella con il pulsante > (ad es. Cognome)oppure
selezionare tutti i campi con il pulsante >>; cliccare su avanti.
Digitare il nome da assegnare alla Query (ad es. Indirizzi Query);
cliccare su Fine.
Per creare una query su due tabelle selezionare la prima tabella su
cui effettuare la query; selezionare il campo della tabella con il
pulsante >; cliccare su avanti. Ripetere questo procedimento
selezionando la seconda tabella. Digitare il nome da assegnare
alla Query ; cliccare su Fine.
Per salvare una query: File/Salva o pulsante a forma di floppy
(Salva) sulla barra degli strumenti.
Per inserire dei criteri di ricerca assegnati occorre visualizzare la
query appena creata in modalità Struttura e alla voce "criteri"
nella parte inferiore della finestra, digitare la formula che
interessa.
Ecco alcuni esempi:
nel campo "NumTessera" digitare il criterio =2 se si cerca un
cliente con numero tessera uguale a 2;
nel campo "Cognome" digitare il criterio R* se si cerca un cliente
col cognome che inizia per R;
nel campo "Nome" digitare il criterio *A se si cerca un cliente col
nome che finisce per A;
nel campo Età digitare il criterio >22 se si cerca un cliente con età
maggiore di 22
utilizzando i
seguenti
operatori: <
(minore di), <=
(minore di o
uguale a), >
(maggiore di),
>= (maggiore di
o uguale a), =
(uguale), <>
(diverso), And,
Or.
5.5 Report
Ecco alcuni esempi:
nel campo "NumTessera" digitare il criterio >10 And <20 se si
cerca un cliente con numero tessera compreso fra 10 e 20;
#10# Or #20# se si cerca un cliente con numero tessera 10 o 20
nel campo "Cognome" digitare il criterio "Rossi" Or "Bianchi"
se si cerca un cliente con uno di questi due cognomi.
5.4.2.3
Modificare una Selezionare la query, cliccare sul pulsante Struttura nella barra
query inserendo, degli strumenti, nella riga "Criteri" cancellare o inserire nuovi
eliminando
criteri
criteri.
5.4.2.4
Modificare una
query:
aggiungere,
eliminare,
spostare,
nascondere,
mostrare campi.
Cliccare sopra al nome del campo, selezionando tutta la colonna;
Per aggiungere: menu Inserisci/Colonna viene inserita una
colonna vuota a sinistra di quella selezionata, quindi posizionarsi
sulla prima cella e scegliere il nome del campo dal menu a
tendina;
oppure fare doppio clic sul campo desiderato (nella tabella
visualizzata nella parte superiore della finestra) il campo verrà
automaticamente inserito nella prima colonna vuota della
struttura della query;
oppure trascinare il campo con la tecnica del Drag & Drop dalla
tabella in una colonna vuota (o nel punto desiderato) nella
struttura della query.
Per eliminare: posizionarsi sulla colonna, menu
Modifica/Elimina o tasto CANC.
Per spostare: trascinare la colonna fino a portarla nel punto esatto
in cui la si vuole spostare (opp. utilizzare il taglia/incolla dalla
barra degli strumenti) ;
Per nascondere: (questa operazione permette di non cancellare un
campo, ma di non visualizzarlo fra i risultati della query) togliere
il segno di spunta nella riga "Mostra"
Per mostrare: aggiungere il segno di spunta nella riga "Mostra"
5.4.2.5
Eseguire una
query.
Menu Query/Esegui o cliccare sul pulsante ! (Esegui) nella barra
degli strumenti.
5.4.2.6
Cancellare una
query.
Selezionare la Query dalla finestra Database, menu
Modifica/Elimina (oppure pulsante X (Elimina) dalla barra
degli strumenti oppure tasto destro del mouse/Elimina oppure
tasto CANC da tastiera)
5.4.2.7
Salvare e
chiudere una
query.
File/salva (se si vuole mantenere lo stesso nome alla Query)
File/Salva con nome (se si vuole cambiare nome creandone una
copia).
Per chiudere la query cliccare sul pulsante a croce nella barra del
titolo della query o File/Chiudi dalla barra dei menu di Access
5.4.3
Ordinare i
record
5.4.3.1
Riordinare i dati
in una tabella,
maschera,
risultato di una
query, in ordine
numerico
crescente,
decrescente, e in
ordine
alfabetico.
Visualizzare tabella, o maschera, o risultato di una query in
modalità Visualizza foglio dati (lo si può fare cliccando sul
pulsante "Apri") selezionare la colonna rispetto alla quale si
vuole ordinare e cliccare sui pulsanti della barra degli strumenti
AZ (ordinamento crescente) ZA (ordinamento decrescente).
Attenzione: per le maschere non è necessario selezionare
alcunchè.
5.5.1
5.5.1.1
Creare e salvare Il report (rapporti) consente di personalizzare la stampa dei dati di
Operare con
i report
un report basato una tabella o query in modo professionale.
su una tabella,
Nella finestra di sinistra del database selezionare l'oggetto:
query.
Report, quindi cliccare sul pulsante Nuovo della barra degli
strumenti selezionare Creazione guidata report e scegliere la
tabella o la query sulla base della quale creare il report (es.
Tabella Indirizzi); selezionare i campi da includere (es. Nome,
Cognome, Indirizzo, professione, Telefono Abitazione), cliccare
su Avanti; scegliere se si desidera aggiungere livelli di gruppo
(cioè raggruppare i campi per qualche campo esistente, ad es.
raggrupparli per Categoria, o per Professione,..), questa opzione
spesso non viene richiesta alla creazione del report, ma
successivamente (vedi 5.5.1.3); cliccare su Avanti; nelle finestre
successive si scelgono l'ordinamento (es. per Cognome in ordine
crescente), il layout e gli stili; indicare un titolo per il report (es.
Indirizzi) che in questo momento verrà salvato quindi scegliere se
visualizzare il report in modalità struttura (per modificarlo) o in
modalità anteprima (per vedere il risultato visivo); cliccare Fine
5.5 1.2
Modificare la
collocazione dei
campi di dati e le
intestazioni
all’interno di un
report.
Aprire il database selezionare l'oggetto: Report, quindi
selezionare il report da modificare; cliccare sull'icona Visualizza
struttura. Si apre una finestra in cui è possibile modificare la
collocazione dei campi utilizzando la tecnica del Drag & Drop.
Per modificare le dimensioni: cliccare sull'oggetto e trascinare i
margini;
Per cancellare: cliccare sull'oggetto e premere tasto CANC;
Per inserire oggetti: nella casella degli strumenti cliccare
sull'oggetto desiderato cliccare nel punto in cui lo si desidera e
trascinarlo ingrandendolo a piacere.
Per modificare le intestazioni si procede allo stesso modo visto
per le maschere:
menu Visualizza/Intestazioni e piè di pagina di un record
cliccare col tasto sinistro del mouse all'interno dell'intestazione e
apportare le modifiche.
Per modificare l'altezza o la larghezza delle intestazioni
posizionare il puntatore sul bordo inferiore o destro della sezione
e trascinare il margine.
Attenzione: il contenuto delle sezioni Intestazione di Rapporto
e Piè di pagina di Rapporto verrà stampato una sola volta
all'inizio e alla fine del report (quindi può essere usata per i titoli
all'inizio del report o per eventuali totali o somme o altro che
verranno stampati alla fine del report); quanto immesso nelle
sezioni Intestazione Pagina e Piè di pagina Pagina verrà
riprodotto all'inizio e alla fine di ogni pagina del report risultante
(possono essere usati per inserire immagini, linee, testi o altro che
si vuole stampare in tutte le pagine).
Infine il contenuto delle sezioni Intestazione Sezione e Piè di
pagina Sezione verrà visualizzato solo in corrispondenza della
propria area di raggruppamento dati.
5.5.1.3
Raggruppare i
dati sotto
un’intestazione
specifica
(campo) di un
report in ordine
crescente,
decrescente.
Aprire il database selezionare l'oggetto: Report, quindi
selezionare il report da modificare; cliccare sull'icona Visualizza
struttura. Raggruppare i dati sotto un’intestazione specifica
significa raggruppare i campi per qualche campo esistente, ad es.
raggrupparli per Categoria, o per Professione,...essi verranno così
presentati nel report in ordine rispetto alla categoria, o
professione (Quello che nella creazione guidata del report veniva
chiamato "aggiungere livelli di gruppo"); per apportare questa
modifica ad un report già creato, si procede nel modo seguente:
Menu Visualizza/Ordinamento e Raggruppamento si apre una
finestra divisa in due parti: in quella superiore sono elencati i
campi per i quali si vogliono definire livelli di raggruppamento e
il loro ordine (es. nella colonna campo inserire i campi
"Cognome" con criterio Crescente e "Professione" con criterio
Crescente).
Nella parte inferiore si trovano le Proprietà gruppo; qui è
necessario impostare le proprietà Intestazione (gruppo) e Piè di
pagina (gruppo) sul valore Sì (nelle altre caselle scegliere
Raggruppa secondo "Ogni valore", Intervallo di
raggruppam. "1", Stampa sezione unita "Nessuno".
5.5.1.4
Presentare campi
specifici in un
report
raggruppati per
somma, minimo,
massimo, media,
conteggio, con
punti di
interruzione
adeguati.
- Durante la creazione guidata di un report: fare clic sul
pulsante Opzioni di riepilogo presente nella pagina Tipo di
ordinamento. Dopo aver fatto clic sul pulsante, si apre
un'ulteriore finestra di dialogo che contiene:
- sulla sinistra il nome dei campi sui quali e`
possibile
calcolare uno dei quattro valori statistici
(Somma, Media,
Minimo e Massimo)
- sulla destra due caselle di opzione nell'area Mostra, chiamati
rispettivamente Dettaglio e
riepilogo e Solo riepilogo.
Per avere uno o più dei valori statistici disponibili, occorre fare
clic (spuntare) sulla casella di selezione corrispondente.
I dati risultanti verranno riportati nel record solamente come
valori riepilogativi o anche in dettaglio, secondo la scelta eseguita
sulle corrispondenti caselle di opzione sulla destra.
- Conteggio dei gruppi di record: viene automaticamente inserito
nel report se una delle opzioni (somma ecc.) è scelta.
5.5.1.5
Inserire,
modificare il
testo
nell’intestazione,
piè di pagina di
un report.
Aprire il database selezionare l'oggetto: Report, quindi
selezionare il report da modificare; cliccare sull'icona Visualizza
struttura.
Nella finestra che appare compaiono tre aree: “intestazione
report”; "corpo"; “Piè di pagina report” (se così non fosse
Visualizza/Intestazione e piè di pagina di un report). Il corpo
contiene i controlli (cioè gli oggetti ) che sono di due tipi:
etichette (titolo o nome dei campi) caselle di testo (quelle
bianche con i dati).
Nell’area “intestazione report” e “Piè di pagina report” è
possibile inserire testo: cliccare sul pulsante Aa (Etichetta) della
Casella degli strumenti: e aprire un rettangolo, quindi digitare il
testo e premere INVIO. (attenzione per formattare il testo si deve
formattare tutta l'etichetta, cioè uscire dall'etichetta, poi
selezionarla e modificarne il formato).
Per modificare testo: cliccare due volte all'interno dell'etichetta e
fare le modifiche.
Attenzione: se si inserisce una casella di testo (pulsante ab nella
casella degli strumenti) per visualizzare un nuovo campo bisogna
associargli un campo della tabella: cliccare con il tasto destro del
mouse sull'oggetto, dal menu contestuale scegliere Proprietà,
nella scheda Dati, nella casella Origine Controllo selezionare il
campo che interessa.
Suggerimento: se non si desidera che i controlli di campo
vengano automaticamente associati a un'etichetta, la si selezioni e
la si tagli, successivamente può essere incollata ovunque si voglia
(es: l'etichetta può essere posizionata nell'intestazione di pagina e
il controllo di campo nel corpo del report)
5.5.1.6
Cancellare un
report.
Nella finestra DB selezionare il report, menu
Modifica/Elimina/OK (opp. pulsante X (Elimina) della barra
degli strumenti, opp. cliccare con il pulsante destro del mouse,
selezionare Elimina)
5.5.1.7
Salvare e
chiudere un
Per salvare: File/Salva
Per chiudere: cliccare sul pulsante a croce nella barra del titolo
report.
5.6
5.6.1
5.6.1.1
Preparazion Preparazione
e della
Stampa
5.6.2
Opzioni di
stampa
del report o File/Chiudi dalla barra dei menu di Access
Visualizzare in Fare clic sull'icona dell'oggetto (tabella, maschera, o report) nella
anteprima di
finestra principale del database; poi
stampa una
tabella,
 Nella barra degli strumenti Database fare clic sull'icona
maschera, report.
Anteprima di stampa (che reca il disegno di una piccola
lente d'ingrandimento su un foglio bianco)
 oppure: nella Barra dei menu fare clic su File/Anteprima di
stampa
5.6.1.2
Modificare
l’orientamento
del report:
verticale,
orizzontale.
Cambiare le
dimensioni della
carta.
Menu File/Imposta pagina si aprirà l'omonima finestra di
dialogo; cliccare sulla scheda Pagina;
per modificare l'orientamento: ; nell'area "Orientamento"
cliccare sull'opzione Verticale o Orizzontale, quindi cliccare su
OK;
per modificare le dimensioni: nell'area "Foglio", scegliere la
Dimensione dal menu a discesa (cliccando sulla freccia accanto
alla casella "Dimensioni") quindi cliccare su OK
5.6.2.1
Stampare [2] una
pagina, record
selezionato/selez
ionati, tabella
completa.
Per stampare una tabella: fare clic sul pulsante Tabella nella
finestra di lavoro del database cliccare sull'icona della tabella da
stampare, dalla barra dei menu File/Stampa si apre una finestra
di dialogo:
 per stampare la tabella completa: confermare la stampa
facendo clic sul pulsante OK
 per stampare una pagina: nell'area "Intervallo di stampa"
selezionare Pagine Da: A: e digitare il numero della pagina
da stampare; poi fare clic sul OK.
 Per stampare record selezionato/i: è necessario prima aprire la
tabella in modalità Foglio dati, quindi selezionare il/i record
che si desidera stampare; poi procedere come sopra: menu
File/Stampa nell'area "Intervallo di stampa" cliccare su
"Record selezionato/i"; confermare la stampa facendo clic su
OK.
Note
5.6.2.2
Stampare tutti i
record, o pagine
specificate,
usando la
visualizzazione
maschera.
Fare clic sull'oggetto Maschere nella finestra di lavoro del
database; cliccare sull'icona della maschera che si intende
stampare; dalla barra dei menu scegliere File/Stampa; nell'area
"Intervallo di stampa" selezionare "Tutto" se si desidera
stampare tutti i record; selezionare "Pagine Da: A:" Per
stampare pagine specificate e digitare il numero di pagina
all'interno delle caselle.
5.6.2.3
Stampare il
risultato di una
query.
Fare clic sull'oggetto Query nella finestra di lavoro del database;
cliccare sull'icona della query che si intende stampare; dalla barra
dei menu scegliere File/Stampa
5.6.2.4
Stampare una o
più pagine
specificate di un
report, un report
completo.
Fare clic sull'oggetto Report nella finestra di lavoro del database;
cliccare sull'icona del report che si intende stampare; dalla barra
dei menu scegliere File/Stampa; nell'area "Intervallo di
stampa" selezionare "Tutto" se si desidera stampare il report
completo; selezionare "Pagine Da: A:" per stampare pagine
specificate e digitare il numero di pagina all'interno delle caselle.
[1] L'attuale Syllabus ECDL per il Modulo 5 si basa su software di database che utilizza un modello di tipo
relazionale
[2] La conoscenza della funzione "Stampa su file", anche se non inclusa ufficialmente tra gli argomenti del
Syllabus. può essere richiesta ai candidati qualora nel Test Center sia precluso l'uso della stampante
Scarica
Random flashcards
Prova Lavoro

2 Carte nandoperna1

biologia

5 Carte patty28

Triangoli

2 Carte oauth2_google_d2543822-c1b0-4efc-972b-1e120768c5d0

il condizionale

2 Carte oauth2_google_2e587b98-d636-4423-a451-84f012b884f0

economia

2 Carte oauth2_google_89e9ca76-2f16-41bf-8eae-db925cb2be4b

creare flashcard